setup needs your help

The latest build is running, but cannot be accessed by either IP or Nginx proxied URL at
If anyone wants to take a stab on it via Unicorn, please do. I cannot figure it out. Perhaps it is an easy fix. Good luck!

Here is the Nginx configuration

Docker log rocketchat

docker-compose.yml file

docker ps

CONTAINER ID        IMAGE                           COMMAND                  CREATED             STATUS                PORTS                    NAMES
c7139f6a7545        rocketchat/   "bash -c 'for i in `…"   17 minutes ago      Up 17 minutes>3000/tcp   rocketchat
60526220ed91        mongo:4.0                       "docker-entrypoint.s…"   17 minutes ago      Up 17 minutes         27017/tcp                mongo

The rocketchat service is set to run on port 4000 inside the container. The docker-compose.yml file specified that port 3000 in the container should be forwarded to 4000 on the host. I changed the port forwarding line in said file to forware port 4000 in the container to 4000 on the host (changed line 30 from - 4000:3000 to - 4000:4000). I then ran docker-compose down followed by docker-compose up to use the new settings. I think this worked since is back up now.


Rad, it is up and running! Self registration is auto-approved, optional e2e encryption is enabled for private rooms, and anonymous users are allowed read + comment access on public rooms like this one.

Some possible Todos for anyone feeling like getting their hands dirty…